phoenitydawn

March 19th, 2007

verschwindende und zurückgewiesene Mails

Posted by Dunedan in Computer, Internet

Wie einige sicher wissen habe ich ja einen eigenen Webserver, auf dem unter anderem auch dieses Blog läuft.
In letzter Zeit hab ich mal angefangen die ursprüngliche Konfiguration der einzelnen Dienste, die ich damals mittels VHCS gemacht hatte, zu hinterfragen. Um es kurz zu sagen: Die Konfiguration von VHCS war scheiße und ich bin sehr froh dass ich es schon länger nicht mehr nutze. Genauso froh bin ich darüber zu wissen dass es noch ein beschisseneres Webkonfigurationsfrontend für Server gibt als VHCS. Und zwar DTC. Darauf bin ich nur gestoßen als ich mitbekam dass es in das offizielle Debian-Repository aufgenommen wurde. Daraufhin schaute ich mir mal den Sourcecode von DTC an und bekam sowohl Lach-, als auch Weinanfälle. Der Code ist echt beschissen und es dauerte auch nicht lange bis ein paar Bekannte und ich einen Bug gefunden hatten mit einem normalen Nutzeraccount bei DTC die gesamte Datenbank löschen zu können.
Gut, aber darüber wollte ich heute eigentlich nicht philosophieren. 😀 Vielmehr wollte ich auf ein paar lustige Problemchen zu sprechen kommen die mir beim aktualisieren der Konfiguration meines Mailservers unterkamen.
Mailserver sind ja in Zeiten von Spam bekanntermaßen die sensibelsten Dienste, wenn es darum geht Mails direkt an andere Provider zu senden. So ereilte es auch mich, dass aufgrund der sehr restriktiven Anti-Spam-Maßnahmen von GMX auf einmal keine Mails mehr an GMX zugestellt werden konnten. Entschuldigend muss man sagen das GMX sehr vorbildlich ist was die zurückgegebenen Fehlermeldungen und Hilfen für Administratoren angeht. Kurz nachdem das Problem mit GMX sich erledigt hatte ereilte es mich mit web.de.
Auf einmal wollte web.de keine Mails mehr von meinem Server annehmen. Da sah es mit den Tipps was man denn machen solle damit die Mails durchkommen schon etwas schlechter aus. Denn aus meiner Sicht erfüllte mein Server alle dafür notwendigen Anforderungen. Daraufhin schrieb ich an das Anti-Spam-Team von web.de welche erst wieder auf die Seite mit den, für mich, nutzlosen Tipps verwiesen und mir dann unterstellten dass mein Server gehackt worden sei (wobei ich vorher ausdrücklich geschrieben hatte das ich was an der Konfiguration meines Mailservers geändert hatte). Aber im Endeffekt konnte auch das alles geklärt werden und web.de nahm wieder Mails von mir an.
Heute nun erwischte es Hotmail. E-Mails die von meinem Server aus an Adressen bei Hotmail geschickt werden, werden zwar von Hotmail angenommen, allerdings mit dem Verweis “Queued mail for delivery”, was ja an sich nichts besonderes ist. Allerdings erreichen diese Mails nie ihr Zielpostfach. Ich gehe davon aus dass das auch wieder an den Anti-Spam-Maßnahmen liegt, aber normalerweise würde ein Provider die Mail einfach abweisen statt sie anzunehmen und danach verschwinden zu lassen um dem Administrator des sendenden Mailservers eine Chance zu geben den Fehler zu finden und zu beheben.
Auf den Supportseiten findet man zu diesem Thema auch nicht viel erhellendes, aber was noch viel schlimmer ist: Es scheint nirgends eine Kontaktadresse für solcherlei Probleme zu stehen. Zumindest habe ich noch keine gefunden. Vielleicht ist diese Kontaktadresse ja auch einfach so “verschwunden”. 😉
Da merkt man dass es heutzutage nahezu an ein Wunder grenzt dass E-Mails korrekt zugestellt werden. Gut, immerhin gibt es bei E-Mails auch im Gegensatz zur herkömmlichen Post ein Problem mit Spam. Wobei ich als Betreiber eines E-Mail-Dienstes immer versuchen würde darauf zu achten dass möglichst alle relevanten Mails für meine Nutzer durchkommen. Nachrichten schon auf Verbindungsebene zu filtern mag zwar ressourcenschonende Sache sein, aber sie bringt für Nutzer auch nur wieder Probleme mit sich.

Leave a Reply

  • :mrgreen:
  • :neutral:
  • :twisted:
  • :shock:
  • :smile:
  • :???:
  • :cool:
  • :evil:
  • :grin:
  • :oops:
  • :razz:
  • :roll:
  • :wink:
  • :cry:
  • :eek:
  • :lol:
  • :mad:
  • :sad: